<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>North Rose-Wolcott honors Athletic Hall of Fame inductees</title><meta property=og:title content="North Rose-Wolcott honors Athletic Hall of Fame inductees"/><link rel=amphtml href=https://amp.waynepost.com/amp/4976484001 /><meta property=article:author content="COURTESY OF NORTH ROSE-WOLCOTT CENTRAL SCHOOL DISTRICT"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.waynepost.com /><link rel=preconnect href=https://user.waynepost.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=preconnect href=https://cdn.tinypass.com /><link rel=dns-prefetch href=//cdn.tinypass.com /><link rel=preconnect href=https://experience.tinypass.com crossorigin/><link rel=dns-prefetch href=//experience.tinypass.com /><link rel=preconnect href=https://buy.tinypass.com /><link rel=dns-prefetch href=//buy.tinypass.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.waynepost.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.waynepost.com/NWAP-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3d4b24644.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=https://cdn.tinypass.com/api/tinypass.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-0be9f6c1.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/72d38a1b-be4e-4f37-a43c-f1cd4daf809b/d15841cd-d131-4653-bd71-e152f64faed9/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4971334001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame."/><meta property=og:description content="The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame."/><meta property=fb:pages content=1068045249902716 /><meta property=fb:app_id content=1608219602670610 /><link rel=canonical href=https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/ /><meta property=og:url content=https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/ /><meta property=og:site_name content="Wayne Post"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?crop=1535,864,x0,y307&width=1535&height=864&format=pjpg&auto=webp"/><meta property=og:image:width content=1535 /><meta property=og:image:height content=864 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?crop=1535,864,x0,y307&width=1535&height=767&format=pjpg&auto=webp"/><meta name=twitter:site content=@ /><meta name=twitter:creator content=@ /><meta name=twitter:title content="North Rose-Wolcott honors Athletic Hall of Fame inductees"/><meta name=twitter:description content="The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Wayne Post" data-t-l=:n|v|c|logo><svg id=gnt_svg_lg fill=#303030 class=gnt_n_lg_svg preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.64 54.63"><path d="M52.14 6.35c.38-1.15.7-2.29 1.58-3.19.55-.56 1.43-1.21 2.21-1.28h1.43V0H44.71v1.88h1.53c.81 0 1.65-.04 2.38.39.45.26.79.68.95 1.19.07.27.11.55.1.83a5.9 5.9 0 01-.41 1.99l-.82 2.63-1.12 3.6-1.3 4.15-1.35 4.31-1.27 4.07-1.07 3.4-.73 2.34-.27.87-8.72-27.19-.17-1.05c-.02-.51.21-1 .6-1.32.4-.33 1.59-.21 2.25-.21h2.62V0H20.1v1.88h1.55a4.45 4.45 0 013.58 2.98l2.3 7.53-6.05 19.41-.36-1.09-1.9-5.78-2.69-8.19-2.52-7.65-.89-2.71c-.36-.98-.58-2.01-.66-3.05-.04-.31.02-.62.16-.9.38-.56 1.36-.53 1.97-.53.85-.03 1.69 0 2.54 0V0H0v1.88l1.48.02c1.13-.03 2.86 1.24 3.66 3.26l11.94 37.09h3.38l8.06-26.49 8.45 26.49h3.33l.08-.22.43-1.3.75-2.28 1.01-3.06 1.2-3.65 1.33-4.04c.48-1.43.95-2.82 1.39-4.23s.93-2.81 1.39-4.22l1.32-4.03 1.19-3.63c.35-1 .68-2.02 1-3.04.26-.72.51-1.46.75-2.2zm27.77 30.2c.06-.41.08-.83.09-1.24v-1.38h-1.96v.92a9.2 9.2 0 01-.5 3.33c-.34.84-.77 1.27-1.29 1.27-.89 0-1.34-.79-1.34-2.38v-17.9c0-2.16-.95-3.91-2.86-5.24-1.9-1.33-4.43-2-7.57-2-3.35 0-6.14.76-8.37 2.27-2.23 1.51-3.34 3.39-3.33 5.63a3.83 3.83 0 001.12 2.86 4.32 4.32 0 005.44.26 2.82 2.82 0 00.98-2.24 3.04 3.04 0 00-.34-1.62 7.5 7.5 0 00-1.62-1.51c-.37-.35-.56-.62-.56-.81.01-.38.17-.73.45-.99 1.09-1.24 2.62-1.86 4.6-1.86 3.63 0 5.45 1.61 5.45 4.82v4.06c-.81.45-1.64.86-2.49 1.22-.57.23-1.83.66-3.78 1.28a50.38 50.38 0 00-6.25 2.41 9.74 9.74 0 00-3 2.29c-.97 1.31-1.46 3.04-1.46 5.16 0 2.4.75 4.29 2.24 5.68s3.49 2.09 5.99 2.09c1.73.04 3.45-.36 4.99-1.16 1.55-.9 2.84-2.17 3.75-3.71.3 3.33 2.08 4.99 5.34 4.99 1.78 0 3.1-.35 3.97-1.07s1.55-1.97 2.03-3.77c.12-.67.22-1.22.28-1.66zm-11.64-4.66a8.42 8.42 0 01-1.62 5.24 4.91 4.91 0 01-4.04 2.12 3.86 3.86 0 01-3.1-1.35 5.56 5.56 0 01-1.15-3.68c0-.62.06-1.24.2-1.85.12-.54.35-1.06.68-1.51a7.21 7.21 0 012.44-2.38 68.2 68.2 0 016.26-3.33l.34-.12v6.86zm66.25 5.67V19.73c0-1.61-.23-2.83-.7-3.67a6.48 6.48 0 00-2.76-2.98 8.78 8.78 0 00-8.01-.23 9.43 9.43 0 00-3.14 2.35c-.4.48-.65.77-.76.92-.04.06-.03.03-.02 0l-.17.35V12.4c-.43.06-.48.15-1.29.26H97.11v1.67h1.19c2.09 0 3.13.57 3.13 1.72l-.21.89L95.98 32l-5.39-15.01a2.96 2.96 0 01-.38-1.33c0-.89.65-1.33 1.95-1.33h1.9v-1.67H79.07v1.67h.42c1.51 0 2.62.87 3.33 2.62l9.72 24.32-1.8 4.34c-1.77 4.67-3.66 7.01-5.68 7.02-.76 0-1.14-.22-1.14-.67 0-.19.24-.5.7-.95.57-.44.86-1.18.87-2.22a3.11 3.11 0 00-.87-2.28 2.94 2.94 0 00-2.22-.89 3.27 3.27 0 00-2.54 1.17 4.08 4.08 0 00-1.03 2.78 4.64 4.64 0 001.65 3.59 5.91 5.91 0 004.03 1.48c2.56 0 4.65-1.41 6.28-4.23.68-1.2 1.26-2.45 1.72-3.75l10.98-29.76c.61-1.7 1.93-2.56 3.95-2.56h2.96c1.13.33 1.69 1.36 1.69 2.82v20.41c0 1.84-.83 2.75-2.49 2.75h-1.32v1.72h14.28v-1.72h-1.62c-1.62 0-1.85-.91-1.85-2.75V22.48c0-2.22 1.22-4.57 3.27-5.56a3.97 3.97 0 013.06-.19c2.12.8 2.32 3.33 2.32 5.28v15.54c0 1.84-.44 2.75-1.99 2.75h-1.56v1.72h14.43V40.3h-1.53c-1.71.01-2.57-.9-2.57-2.74zm31.09-14.16a21.2 21.2 0 00-1.06-3.84 11.23 11.23 0 00-4.35-5.47 11.97 11.97 0 00-6.86-2.03 12.63 12.63 0 00-9.79 4.41c-2.63 2.94-3.95 6.59-3.95 10.95 0 4.44 1.32 8.09 3.95 10.95a13.01 13.01 0 0010 4.28c2.36.05 4.69-.56 6.72-1.76a10.74 10.74 0 004.32-4.98c.26-.51.47-1.04.63-1.59.16-.75.28-1.51.34-2.28 0 .04-2.18 0-2.38 0-.56 2.34-1.43 4.8-3.47 6.25a8.02 8.02 0 01-9.24-.34 8.85 8.85 0 01-2.72-4.51 21.5 21.5 0 01-.56-5.71l18.73.05c.02-1.46-.09-2.93-.31-4.38zm-7.95 2.07l-10.33.05c0-3.93.14-6.83 1.2-8.68.95-1.63 2.8-2.83 4.62-2.65.66.07 1.29.31 1.82.71a5.84 5.84 0 011.87 2.66c.81 2.2.82 4.57.82 6.88v1.03zM210.54 3.1C207.68.72 203.58.32 200.02.32H180.6v1.74h2.79c.13.04.27.06.41.09.14.03.28.08.41.15.43.09.84.28 1.18.56.39.31.58.99.58 2.03v32.56c0 1.9-.86 2.86-2.58 2.86h-2.98v1.73h18.74V40.3h-3.42l-.82-.18-.95-.52a2.98 2.98 0 01-.66-2.15V22.64h5.24c2.4.07 4.8-.19 7.14-.75 2.49-.66 4.47-1.59 5.96-3.54a11 11 0 002.22-6.85c.01-3.13-.83-6.33-3.32-8.4zm-8.81 16.76a9.01 9.01 0 01-3.86.81h-4.51V4.04c0-.78.13-1 .39-1.28.39-.31.89-.44 1.39-.38h3.4c4.35 0 6.72 2.94 6.72 9.55-.01 4.43-1.27 6.66-3.53 7.93zm57.07 5.06c-2.19-.95-4.53-1.59-6.66-2.62a6.82 6.82 0 01-2.6-1.9c-1.23-1.62-.95-4.26.72-5.43a5.14 5.14 0 013.59-.69 9 9 0 017.52 8h1.81V12.11h-1.83c.05.76 0 1.68-.63 2.05s-1.31 0-1.9-.3a21.56 21.56 0 00-3.33-1.49c-3.47-1.1-7.56-.36-10.17 2.18-2.61 2.54-3.41 6.87-1.57 10 1.28 2.18 3.56 3.57 5.88 4.55s4.78 1.64 7.01 2.83a5.21 5.21 0 012.34 2.09 5.22 5.22 0 01-.19 4.59 4.01 4.01 0 01-3.14 1.86 7.24 7.24 0 01-3.63-.78 12.43 12.43 0 01-6.95-9.52h-1.9v12.24h1.85c-.06-.87 0-1.97.8-2.32.61-.28 1.32.06 1.9.39 1.69.95 3.4 1.94 5.29 2.38a9.93 9.93 0 0012.1-8.23 8.39 8.39 0 00-.83-5.19c-1.18-2.14-3.29-3.54-5.48-4.52zm24.62 9.04v.22c0 1.98-.05 2.86-.48 3.81a2.17 2.17 0 01-1.88 1.39c-.6.05-1.19-.22-1.54-.71a3.53 3.53 0 01-.51-2.08V15.27h5.81V12.7h-5.81V1.72h-1.97c-.19 1.1-.41 3.75-.67 4.48a10.8 10.8 0 01-5.38 6.05 15.9 15.9 0 01-3.23 1.07v1.93h4.28v21.39c0 4.25 2.28 6.35 6.31 6.37 3.74 0 5.96-1.26 6.66-3.43.21-.83.36-1.67.45-2.51.12-1.04.18-2.09.17-3.13l-2.21.02zm-56.9-21.83c-7.76 0-13.18 6.31-13.18 15.35 0 8.79 5.55 15.18 13.18 15.18 7.64 0 13.08-6.38 13.08-15.18s-5.63-15.35-13.08-15.35zm4.62 15.54c0 3.18 0 6.47-.61 9.02-.69 2.81-1.98 4.13-4.06 4.13-2.08 0-3.33-1.29-4.01-4.05-.63-2.48-.63-5.76-.63-8.9v-.76c0-3.18 0-6.47.61-9.01.68-2.81 1.95-4.11 4.01-4.11s3.37 1.33 4.06 4.19c.61 2.58.61 5.91.61 9.12l.02.37z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.waynepost.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021MAYFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.waynepost.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021MAYFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://obituaries.mpnnow.com/obituaries/mpnnow/ data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.waynepost.com/user/enewspaper/ data-t-l=:n|v|c|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.newyorkpublicnotices.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Canandaigua" title="Weather in Canandaigua" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.waynepost.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021MAYFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.waynepost.com/NWAP-GUP/authenticate?success-url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F&cancel-url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-ny-waynecounty-C6578-high_impact-sports-preps-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=High-school data-c-ssts=HIGH-SCHOOL></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>North Rose-Wolcott honors Athletic Hall of Fame inductees</h1><div class=gnt_ar_by>COURTESY OF NORTH ROSE-WOLCOTT CENTRAL SCHOOL DISTRICT</div><div class=gnt_ar_dt aria-label="Published 2:52 p.m. ET May 6, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/ data-ss-t="North Rose-Wolcott honors Athletic Hall of Fame inductees" data-ss-d="The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1608219602670610&href=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F&text=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees%20-%20from%20Wayne%20Post&body=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees%0A%0AThe%20North%20Rose-Wolcott%20Central%20School%20District%20inducted%20five%20people%20into%20its%20Athletic%20Hall%20of%20Fame.%0A%0ACheck%20out%20this%20story%20on%20waynepost.com%3A%20https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - Uninvited gator sends soccer players scrambling"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;ny-waynecounty-C6578&#34;,&#34;pn&#34;:&#34;Wayne Post&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;sports/sportskind&#34;,&#34;byline&#34;:&#34;Sportskind&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-05-06T15:04:30Z&#34;,&#34;credit&#34;:&#34;Sportskind, USA TODAY&#34;,&#34;duration&#34;:57000,&#34;headline&#34;:&#34;Uninvited gator sends soccer players scrambling&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/72d38a1b-be4e-4f37-a43c-f1cd4daf809b/d15841cd-d131-4653-bd71-e152f64faed9/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4971334001&#34;,&#34;id&#34;:&#34;4971334001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/05/06/USAT/0cc6bd29-e582-40c2-8cb0-510ed7e4a560-Gator_scares_soccer_team_16x9_Thumbnail.jpeg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-05-06T15:04:30Z&#34;,&#34;keywords&#34;:&#34;Soccer,Overall Positive,Video Syndication - USAT,Video Syndication – International,Video Syndication - Network Sports&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/72d38a1b-be4e-4f37-a43c-f1cd4daf809b/d15841cd-d131-4653-bd71-e152f64faed9/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/sports/sportskind/2021/05/06/uninvited-gator-sends-soccer-players-scrambling/4971334001/&#34;},&#34;promoBrief&#34;:&#34;Toronto FC players got a taste of the Sunshine State when a giant alligator crashed their practice in Orlando.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-05-06T15:04:30Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;sports&#34;,&#34;subsection&#34;:&#34;sportskind&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;84ca95ef-94ac-4d9e-b8f2-581d098df78e&#34;,&#34;name&#34;:&#34;Soccer&#34;},{&#34;id&#34;:&#34;7095bb07-b172-434b-a4eb-8856263ad949&#34;,&#34;name&#34;:&#34;Overall Positive&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;abb1b69c-143a-47e0-9004-50120aa6b80d&#34;,&#34;name&#34;:&#34;Video Syndication – International&#34;},{&#34;id&#34;:&#34;3cf8d83c-7f05-4079-af78-11e8e3e775c3&#34;,&#34;name&#34;:&#34;Video Syndication - Network Sports&#34;}],&#34;title&#34;:&#34;Uninvited gator sends soccer players scrambling&#34;,&#34;url&#34;:&#34;/videos/sports/sportskind/2021/05/06/uninvited-gator-sends-soccer-players-scrambling/4971334001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/05/06/USAT/0cc6bd29-e582-40c2-8cb0-510ed7e4a560-Gator_scares_soccer_team_16x9_Thumbnail.jpeg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Uninvited gator sends soccer players scrambling" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><p class=gnt_ar_b_p>The North Rose-Wolcott Central School District recently inducted five people into its Athletic Hall of Fame during a ceremony at North Rose-Wolcott High School. </p><p class=gnt_ar_b_p>The Athletic Hall of Fame was established to recognize and celebrate the accomplishments of outstanding athletes, coaches, administrators and Cougar supporters, and enhance current student-athletes’ understanding and appreciation for the positive role models in the tradition of Cougar Athletics. </p><p class=gnt_ar_b_p>Through nomination and committee selection, the Hall of Fame recognizes athletes who have graduated from NR-W a minimum of 10 years, individuals who made significant contributions to NR-W athletic programs as a coach, or individuals who made a significant impact on district, sectional, regional, state, national, professional or international athletics. </p><p class=gnt_ar_b_p>This year’s honorees are Jermel Brown, Mike DeWispelaere, Kelly Lockwood Ferrente, Pete Stewart and Thomas Tathum. </p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:400px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?width=300&height=400&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?width=600&height=800&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="John Sklenar, right, accepts the North Rose-Wolcott Athletic Hall of Fame Award on behalf of Pete Stewart. At left is Duke Mitchell, co-chair of the Hall of Fame Committee."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="John Sklenar, right, accepts the North Rose-Wolcott Athletic Hall of Fame Award on behalf of Pete Stewart. At left is Duke Mitchell, co-chair of the Hall of Fame Committee." data-c-credit="PHOTO PROVIDED"></div></figure><p class=gnt_ar_b_p>Brown, of Wolcott, Class of 2001, was a multi-sport athlete who competed in volleyball, basketball and track and field. In every sport, he was a multi-year recipient of MVP awards and all-tournament selections. He was selected as MVP and an All-County team member multiple times in track and field, a three-time Section V champion and a state champion in the high jump in 1999. Brown continues to hold the NR-W record in high jump at 6 feet, 10 inches.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ny-waynecounty-C6578-native-article_link-sports-preps-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>DeWispelaere, of Wolcott, Class of 1996, was a multi-sport athlete at the highest level in high school, playing baseball and soccer. As a soccer player, DeWispelaere received multiple All-County team selections and, in 1995, was chosen as the Class CC tournament MVP and made the All-Greater Rochester and All-State teams. He currently works with two young men’s soccer teams and a boys baseball team, and plays soccer as a member of the Jets summer soccer league. </p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ny-waynecounty-C6578-native-article_link-sports-preps-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Ferrente, of Newark, Class of 1982, participated in soccer, swimming and volleyball through middle and high school. She received the Robert Bradbury Award in 1982 for her athletic performance, sportsmanship and integrity. Ferrente continued to play soccer in junior college, coached youth soccer teams and served as coach of the NR-W girls soccer team for 10 years.</p><p class=gnt_ar_b_p>Stewart, who died this past January, was known for his coaching and promotion of soccer in the area. He coached at the high school level and ran summer programs. He was instrumental in starting the Jets soccer program and coached for it for many years. Later on, Stewart could be found recording soccer games at many venues. </p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Tathum, former athletic director and basketball coach, was known for demanding the best from his players and all NR-W students. He recognized dedication and differences in abilities, and made a difference in countless students’ lives. Since his retirement, Tathum has been involved with the Central New York National Football Foundation and Special Olympics. He splits his time between Central Square and Naples, Florida.</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/ data-ss-t="North Rose-Wolcott honors Athletic Hall of Fame inductees" data-ss-d="The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1608219602670610&href=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F&text=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees%20-%20from%20Wayne%20Post&body=North%20Rose-Wolcott%20honors%20Athletic%20Hall%20of%20Fame%20inductees%0A%0AThe%20North%20Rose-Wolcott%20Central%20School%20District%20inducted%20five%20people%20into%20its%20Athletic%20Hall%20of%20Fame.%0A%0ACheck%20out%20this%20story%20on%20waynepost.com%3A%20https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-ny-waynecounty-C6578-poster-sports-preps-4 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.waynepost.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F&marketName=waynepost&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ny-waynecounty-C6578-poster_scroll-sports-preps-5 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-ny-waynecounty-C6578-leaderboard_btf-sports-preps-6 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Wayne Post - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.waynepost.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.waynepost.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.newyorkpublicnotices.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.waynepost.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.waynepost.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.waynepost.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.waynepost.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.waynepost.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/new-york/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.waynepost.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.waynepost.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.waynepost.com/subscriberguide class=gnt_ft_a data-t-l=:f|v|c|support:subscriber-guide>Subscriber Guide</a> <a href=https://account.waynepost.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.waynepost.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.waynepost.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.waynepost.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/MessengerPostWayne/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://user.waynepost.com/user/enewspaper/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:e-edition>E-Edition</a> <a href="http://nl.newsbank.com/nl-search/we/Archives?p_product=WPLL&p_theme=gatehouse&p_action=keyword" class=gnt_ft_a data-t-l=:f|v|c|stay-connected:archives>Archives</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/NYMPN class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.billeriq.com/ebpp/GHM340/Login/Index class=gnt_ft_a data-t-l=:f|v|c|our-partners:pay-your-ad-bill>Pay Your Ad Bill</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.waynepost.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3d4b24644.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.waynepost.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.waynepost.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.waynepost.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.waynepost.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.waynepost.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.waynepost.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.waynepost.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.waynepost.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.waynepost.com/NWAP-GUP/user/logout/?return-url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.waynepost.com/NWAP-GUP/authenticate?success-url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F&cancel-url=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.waynepost.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.waynepost.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><script type="gnt/tmpl" data-tmpl-key=vdscta><div class=gnt_em_vp_sbcta><a class=gnt_em_vp_sbcta_sb data-t-l=":d|d|auto subscribe|${t}" target=_blank rel=noopener href="https://subscribe.waynepost.com/specialoffer?gps-source=IUXPLAYEROVERLAY&itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp&onSuccessRedirectURL=https%3A%2F%2Fwww.waynepost.com%2Fstory%2Fsports%2Fhigh-school%2F2021%2F05%2F06%2Fnorth-rose-wolcott-honors-athletic-hall-fame-inductees%2F4976484001%2F">Subscribe</a> <a class=gnt_em_vp_sbcta_dt data-t-l=":d|d|auto included|${t}" target=_blank rel=noopener href="https://cm.waynepost.com/whats-included-subscribe?itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp">What's included?</a></div>|styles|.gnt_em_vp_sbcta{display:flex;flex-direction:column;text-align:center;position:absolute;top:25px;z-index:4;width:400px;height:225px;background:#000;color:#fff;font-family:'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;-webkit-user-select:none;user-select:none}.gnt_em_vp_sbcta::before{content:'Autoplay videos can be distracting. Make them go away.';order:-1;margin:38px 0 0;padding:0 55px;font-size:16px;line-height:20px;font-weight:700}.gnt_em_vp_sbcta::after{content:'Subscribers can turn off autoplay video - and more!';order:-1;margin:6px 0 12px;padding:0 88px;font-size:14px;line-height:16px}.gnt_em_vp_sbcta_sb{width:88px;height:30px;margin:0 156px 9px;border-radius:2px;background:#fff;color:#1665cf;font:700 14px/30px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;text-decoration:none;text-align:center}.gnt_em_vp_sbcta_sb:hover{color:#0a32a0}.gnt_em_vp_sbcta_dt{width:max-content;margin:0 auto;padding:0 2px;outline-offset:1px;color:#fff;font:12px/14px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_em_vp_sbcta_dt:hover{color:#e0e0e0}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3B6sKHzzQebQkoDu0B5hvNTF3r0.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"North Rose-Wolcott honors Athletic Hall of Fame inductees","description":"The North Rose-Wolcott Central School District inducted five people into its Athletic Hall of Fame.","url":"https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.waynepost.com/story/sports/high-school/2021/05/06/north-rose-wolcott-honors-athletic-hall-fame-inductees/4976484001/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?crop=1535,1535,x0,y256&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg?crop=1535,864,x0,y307&width=1535&height=767&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-05-06T18:52:55Z","dateCreated":"2021-05-06T18:52:55Z","dateModified":"2021-05-06T18:52:55Z","articleSection":"sports","publisher":{"@type":"Organization","name":"Wayne Post","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/waynepost/images/site-nav-logo@2x.png"}},"author":["COURTESY OF NORTH ROSE-WOLCOTT CENTRAL SCHOOL DISTRICT"],"keywords":["access:metered","ssts:sports:high-school","type:story","tag:Wayne County, NY","tag:Overall Positive","tag:sport","tag:High School Sports","tag:Awards"],"isAccessibleForFree":false,"hasPart":{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".gnt_ar_b"},"isPartOf":{"@type":["CreativeWork","Product"],"name":" - Unlimited Digital Access","productID":"waynepost.com:standard"},"metadata":"{\"id\":\"4976484001\",\"siteCode\":\"NWAP\",\"contentSourceCode\":\"NWAP\",\"ssts\":\"sports:high-school\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/05/06/NWAP/5e47a9d3-b61d-4c70-8071-b7eb65875ec2-0512_fea_NY_WAY_NRWathletics.jpeg","caption":"John Sklenar, right, accepts the North Rose-Wolcott Athletic Hall of Fame Award on behalf of Pete Stewart. At left is Duke Mitchell, co-chair of the Hall of Fame Committee.","copyrightHolder":"PHOTO PROVIDED"}]</script></body></html>